Widespread Attacks

Incident Report for UFPlanets.com

Resolved

The issue affecting the UFPlanets.com website has been resolved, and all services are back to normal. Thank you for your patience as we worked to sort out this issue.
Posted Jun 11, 2025 - 19:34 BST

Identified

We have identified there is currently a widespread attack affecting multiple web services, including UFPlanets.com. We are analysing the attack patterns and are currently blocking malicious connections.

This attack is intended to disrupt multiple websites around the globe. All of your personal data is secure. Updates will be provided when they become available.
Posted Jun 11, 2025 - 13:02 BST
This incident affected: UFPlanets.com.