Website Performance Degradation

Incident Report for UFPlanets.com

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 19:59 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2025 - 18:49 BST

Investigating

We are currently seeing degraded performance on UFPlanets.com, resulting in slower load times or intermittent access issues. Our team is investigating and will provide updates we work on this issue.
Posted Aug 06, 2025 - 18:39 BST
This incident affected: UFPlanets.com.